Board.KolibriOS.org

Official KolibriOS board
It is currently Sun Nov 29, 2020 2:32 pm

All times are UTC+03:00




Post new topic  Reply to topic  [ 640 posts ]  Go to page Previous 1 2 3 4 543 Next
Author Message
PostPosted: Sun Nov 07, 2010 2:35 pm 
Serge
Ты не расписал подробно - какие драйвера надо перекомпилять, залито ли на SVN, какая ревизия ядра нужна?


Top
   
PostPosted: Sun Nov 07, 2010 3:35 pm 
Offline
Kernel Developer

Joined: Wed Mar 08, 2006 6:25 pm
Posts: 3952
Mario

А логи svn посмотреть не судьба ? Как дети. Всё там. Всегда обновляйте ядро и дрова. Здесь Geode. Надеюсь, что работает. Если есть заметная в лучшую сторону разница (плавная картинка в видеоплеере) со старым драйвером, значит работает правильно.


Top
   
PostPosted: Sun Nov 07, 2010 3:45 pm 
Да, тут проблема была у меня - клиент eSVN под Linux не показывал в логе список измененных файлов. Теперь я разобрался как включить отображение.

Как проверю обязательно отпишусь.


Top
   
PostPosted: Sun Nov 07, 2010 4:14 pm 
Offline
Kernel Developer

Joined: Wed Mar 08, 2006 6:25 pm
Posts: 3952
Тогда извиняюсь.


Top
   
PostPosted: Sun Nov 07, 2010 6:34 pm 
Serge
Не нужно, я бывает сам туплю. :wink:

В общем результаты теста:
1) MP3 в плеере звука проигрывается без задержек и шумов. Это я так к сведению, чтобы было с чем сравнивать.
2) Fplay воспроизводит рывками на всех файлах, независимо от их размера и разрешения видео. Звук в некоторых идет чисто, в других слышно эхо, иногда очень сильное эхо. Такое ощущение, что кусок который в буфере карты успевает повториться раза 2-3. При этом загрузка системы согласно индикатору и CPU не превышала 40-50%.

Вот лог (звук шел чисто, изображение рывками).
Attachment:
BOARDLOG.TXT [504 Bytes]
Downloaded 112 times


Top
   
PostPosted: Sun Nov 07, 2010 7:04 pm 
Offline
Kernel Developer

Joined: Wed Mar 08, 2006 6:25 pm
Posts: 3952
Mario

Рывки с новым драйвером для Geode ? Со старыми дровами должны быть точно.


Top
   
PostPosted: Sun Nov 07, 2010 9:49 pm 
Serge
Да, с новыми, которые ты здесь выложил. Старые не проверял.


Top
   
PostPosted: Sun Nov 07, 2010 10:15 pm 
Offline

Joined: Mon Sep 24, 2007 11:11 am
Posts: 2814
1629е ядро, звуковой драйвер Intel HDA, диск видимый через биос. При попытке воспроизвести пару mpeg4 файлов Page fault. Что новая версия fplay, что старая. К сожалению, фотоаппарата под рукой нет, чтобы показать, что пишется на доску отладки.


Top
   
PostPosted: Sun Nov 07, 2010 11:31 pm 
А почему не 1675? К тому же Serge уже сказал про детей. :mrgreen:


Top
   
PostPosted: Mon Nov 08, 2010 6:49 am 
Offline
Kernel Developer

Joined: Wed Mar 08, 2006 6:25 pm
Posts: 3952
Mario

Ты проверял со старым аудиодрайвером, отсюда и рывки.
Новый выложил http://code.google.com/p/kolibri-pe/downloads/list.


Top
   
PostPosted: Mon Nov 08, 2010 10:49 pm 
Serge
Либо ты вторично залил старый драйвер, либо в первый раз я скачал новый. Файлы в архивах идентичны и по размеру и по дате создания. Соответственно результат при воспроизведении абсолютно такой же, как я описывал выше.
Attachment:
1Boardlog.txt [1.48 KiB]
Downloaded 120 times


Также методом тыка выяснил, что FPLAY кроме контейнера AVI кушает также контейнеры FLV, MOV, MP4, MPG, WMV.


Top
   
PostPosted: Tue Nov 09, 2010 6:34 am 
Offline
Kernel Developer

Joined: Wed Mar 08, 2006 6:25 pm
Posts: 3952
Mario

Я смотрю на страницу http://code.google.com/p/kolibri-pe/downloads/list и вижу a5536.7z AMD Geode AC97 sound driver DownloadCount 0. С каким драйвером ты проверял ? Или ты собирал из исходников ?


Top
   
PostPosted: Tue Nov 09, 2010 10:28 am 
Serge
Я скачивал дома 2 раза, сейчас скачал на работе 2 раза (разными браузерами Opera и IE, так что кэширование исключено) - значение счетчика не поменялось. Размер архива 4116 байт. В архиве два файла 111 байт и 3825 байт соответственно. Из исходников я не собирал.


Top
   
PostPosted: Tue Nov 09, 2010 10:47 am 
Offline

Joined: Mon Sep 24, 2007 11:11 am
Posts: 2814
1675е ядро (из svn 1693), infinity.obj и sound.obj оттуда же, qemu 0.12
Звук в ac97snd есть, fplay запускаю через run командой "/bd0/1/fplay /bd0/1/путь/имя"
Пробовал mp4 и flv файлы. Если файл mp3, то пишет, что не найден video stream, и корректно выходит.
На реальной машине логи примерно такие же.


Attachments:
Снимок.png
Снимок.png [ 14.12 KiB | Viewed 4082 times ]
Top
   
PostPosted: Tue Nov 09, 2010 10:55 am 
Offline
Kernel Developer

Joined: Wed Mar 08, 2006 6:25 pm
Posts: 3952
Mario

И правда не меняется. Наверное он слишким мелкий для Гугла, чтоб его считать.
Без железки не проверить. Фризы и рывки вещь субъективная. Процессор там слабенький, может тормозить. У меня сильные фризы только на одном файле, там неудачное для плеера чередование A/V пакетов.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 640 posts ]  Go to page Previous 1 2 3 4 543 Next

All times are UTC+03:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited