Board.KolibriOS.org

Official KolibriOS board
It is currently Tue Nov 30, 2021 7:03 am

All times are UTC+03:00




Post new topic  Reply to topic  [ 16 posts ]  Go to page 1 2 Next
Author Message
PostPosted: Fri Oct 29, 2021 3:42 am 
Offline

Joined: Thu Oct 28, 2021 4:29 pm
Posts: 15
Hello, I tried to run KolibriOS on my real PC but it's stuck on "Initialize system directory /sys"

I've noticed that the Hard Disk has activity, idk why.

Any help is appreciated


Top
   
PostPosted: Fri Oct 29, 2021 3:57 am 
Offline
Mentor
User avatar

Joined: Mon Oct 19, 2009 10:58 am
Posts: 703
What image do you boot from? What is the boot mode: BIOS or UEFI?
Try one of older images (img, iso, raw), does it work?


Top
   
PostPosted: Fri Oct 29, 2021 8:39 pm 
Offline

Joined: Thu Oct 28, 2021 4:29 pm
Posts: 15
Older versions like 0.7.7.0 work but the latest version is stuck on that message

I boot from BIOS I think


Top
   
PostPosted: Fri Oct 29, 2021 8:58 pm 
Offline
Mentor
User avatar

Joined: Mon Oct 19, 2009 10:58 am
Posts: 703
Here you can find a number of older builds. Try to start from e.g. r9182 and detect the first broken revision. This way it will be easier for us to find and fix the issue.


Top
   
PostPosted: Fri Oct 29, 2021 11:16 pm 
Offline
Mentor
User avatar

Joined: Mon Oct 19, 2009 10:58 am
Posts: 703
Follow the link I provided in my previous post. You will see many different KolibriOS images.
These images differ by their type (floppy, cd, hdd/flash) and revision number (rXXXX, kind of version). The bigger that number is, the more recent version of KolibriOS it corresponds to.
Try to boot images of different revisions to find the revision number N such that image of revision N-1 boots successfully while N doesn't.
My intuition suggests you to start from the revision number 9182.


Top
   
PostPosted: Sat Oct 30, 2021 3:26 am 
Offline

Joined: Thu Oct 28, 2021 4:29 pm
Posts: 15
Ohhhh right.
It works with the revision number 9182


Top
   
PostPosted: Sat Oct 30, 2021 3:31 am 
Offline
Mentor
User avatar

Joined: Mon Oct 19, 2009 10:58 am
Posts: 703
dunkaist wrote:
Try to ... find the revision number N such that image of revision N-1 boots successfully while N doesn't.
Marcelo wrote:
It works with the revision number 9182

Do I understand correctly that r9182 boots successfully and r9183 doesn't?


Top
   
PostPosted: Sat Oct 30, 2021 3:35 am 
Offline

Joined: Thu Oct 28, 2021 4:29 pm
Posts: 15
The r9183 doesn't boot


Top
   
PostPosted: Sat Oct 30, 2021 3:52 am 
Offline
Mentor
User avatar

Joined: Mon Oct 19, 2009 10:58 am
Posts: 703
First use an image of r9183.
On the blue screen enable 'Duplicate debug output to the screen'; choose the biggest supported video mode; boot; take a photo of the screen; attach that photo here.

Then use the latest image, follow the same instructions and attach another photo of the screen.


Top
   
PostPosted: Sat Oct 30, 2021 4:07 am 
Offline

Joined: Thu Oct 28, 2021 4:29 pm
Posts: 15
Now


Attachments:
20211029_220345_Burst01.jpg
20211029_220345_Burst01.jpg [ 2.93 MiB | Viewed 775 times ]
Top
   
PostPosted: Sat Oct 30, 2021 4:09 am 
Offline

Joined: Thu Oct 28, 2021 4:29 pm
Posts: 15
Excuse me for the shifty quality


Top
   
PostPosted: Sat Oct 30, 2021 4:13 am 
Offline

Joined: Thu Oct 28, 2021 4:29 pm
Posts: 15
Let me send you a better pic


Attachments:
20211029_221129_Burst01.jpg
20211029_221129_Burst01.jpg [ 3.36 MiB | Viewed 775 times ]
Top
   
PostPosted: Sat Oct 30, 2021 6:23 pm 
Offline
Mentor
User avatar

Joined: Mon Oct 19, 2009 10:58 am
Posts: 703
I need to know what SATA/AHCI controller you have. To provide this information, please, boot r9182, run PCIDEV program and attach its photo.
Also, what type of image do you boot from: floppy, cd or hdd/flash?


Top
   
PostPosted: Sat Oct 30, 2021 9:08 pm 
Offline

Joined: Thu Oct 28, 2021 4:29 pm
Posts: 15
I boot from flash :)


Attachments:
20211030_150447.jpg
20211030_150447.jpg [ 3.7 MiB | Viewed 677 times ]
Top
   
PostPosted: Mon Nov 01, 2021 10:32 pm 
Offline
User avatar

Joined: Mon Apr 06, 2020 1:09 pm
Posts: 127
Marcelo wrote:
I boot from flash :)

1) Can you tell what is your hard drive model? AHCI driver says "unknown device signature", it's strange..
2) Which disk mode is set in your BIOS: AHCI mode or legacy ATA mode ?

_________________
The best way to predict the future is to create it.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 16 posts ]  Go to page 1 2 Next

All times are UTC+03:00


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited