Board.KolibriOS.org

Official KolibriOS board
It is currently Fri Nov 15, 2019 9:16 pm

All times are UTC+03:00




Post new topic  Reply to topic  [ 400 posts ]  Go to page Previous 123 24 25 26 27 Next
Author Message
PostPosted: Mon Sep 18, 2017 5:23 pm 
Offline
Designer
User avatar

Joined: Thu Jan 25, 2007 3:33 pm
Posts: 5066
Есть недочет:
1. Выделить текст в EditBox
2. Вставить текст из буфера.

Ожидаемый результат: выделенный текст удалился, выделение сбросилось, новый вставился
Фактический результат: текст вставился, тот текст что был сместился вправо, выделение осталось (теперь выделен кусок вставленного текста)

_________________
Через тернии к звездам


Top
   
PostPosted: Mon Sep 18, 2017 10:00 pm 
Offline

Joined: Sun Oct 30, 2011 6:43 pm
Posts: 1499
Leency, #6994
Надо проверить.


Top
   
PostPosted: Wed Sep 20, 2017 10:53 am 
Offline
Designer
User avatar

Joined: Thu Jan 25, 2007 3:33 pm
Posts: 5066
0CodErr
Проверил, ошибок не обнаружил.

_________________
Через тернии к звездам


Top
   
PostPosted: Wed Sep 20, 2017 8:21 pm 
Offline

Joined: Sun Oct 30, 2011 6:43 pm
Posts: 1499
Я в #6965 считал 2 символа резервными.
Но на самом деле так нужно делать для приложений, а не внутри самой библиотеки.
То есть, выделять память под text buffer нужно на 2 больше, чем максимальное количество символов.
Я где-то это читал, но не помню уже где.
Поэтому теперь в #7001 я не считаю их как reserved.


Top
   
PostPosted: Wed Sep 27, 2017 12:52 pm 
Offline

Joined: Sun Oct 30, 2011 6:43 pm
Posts: 1499
Аналогичный баг viewtopic.php?f=24&t=1220&start=345#p69221 с клавишей Home.
Судя по исходнику там одинаковое поведение.


Top
   
PostPosted: Wed Sep 27, 2017 8:04 pm 
Offline

Joined: Sun Oct 30, 2011 6:43 pm
Posts: 1499
Изменил макрос edit_boxes_set_sys_color.
Теперь цвет текста, выделения и фона фиксированный.


Top
   
PostPosted: Thu Sep 28, 2017 10:52 am 
Offline
Designer
User avatar

Joined: Thu Jan 25, 2007 3:33 pm
Posts: 5066
Регрессия: теперь только маленький шрифт http://prntscr.com/gqnei9, был большой viewtopic.php?f=48&t=1515&start=435#p69423

_________________
Через тернии к звездам


Top
   
PostPosted: Fri Sep 29, 2017 11:32 am 
Offline

Joined: Sun Oct 30, 2011 6:43 pm
Posts: 1499
#7033
В Fasm и Kpack цвет шрифта стал зелёным.
Я цвет не менял.
Может так и задумано было изначально?
Но можно принудительно в макросе делать его чёрным.
Некоторые программы всё ещё имеют, как мне кажется, очень тёмный цвет выделения.
Spoiler: Show
Attachment:
1.PNG
1.PNG [ 74.9 KiB | Viewed 4326 times ]


Top
   
PostPosted: Fri Sep 29, 2017 1:58 pm 
Offline
Designer
User avatar

Joined: Thu Jan 25, 2007 3:33 pm
Posts: 5066
> можно принудительно в макросе делать его чёрным.
Думаю, стоит сделать.

> Некоторые программы всё ещё имеют, как мне кажется, очень тёмный цвет выделения.
Надо бы и их пофиксить.

_________________
Через тернии к звездам


Top
   
PostPosted: Fri Sep 29, 2017 2:27 pm 
Offline

Joined: Sun Oct 30, 2011 6:43 pm
Posts: 1499
Leency wrote:
> можно принудительно в макросе делать его чёрным.
Думаю, стоит сделать.
#7034
Leency wrote:
> Некоторые программы всё ещё имеют, как мне кажется, очень тёмный цвет выделения.
Надо бы и их пофиксить.
А это уже к авторам тех программ.


Top
   
PostPosted: Sun Dec 10, 2017 8:51 pm 
Offline
User avatar

Joined: Mon Oct 27, 2008 10:10 pm
Posts: 811
rev 7128
Небольшое исправление в editbox. При 1-м нажатии мышей в editbox виднелась небольшая линия (обычно белого цвета) в левом верхнем углу окна. Происходило затирание линии (курсора) в старых координатах (которые до начала использования editbox равны 0,0).


Top
   
PostPosted: Wed Jan 10, 2018 12:51 pm 
Offline
Designer
User avatar

Joined: Thu Jan 25, 2007 3:33 pm
Posts: 5066
IgorA wrote:
rev 7128
Небольшое исправление в editbox. При 1-м нажатии мышей в editbox виднелась небольшая линия (обычно белого цвета) в левом верхнем углу окна. Происходило затирание линии (курсора) в старых координатах (которые до начала использования editbox равны 0,0).

Видел такое. Спасибо за исправление!

_________________
Через тернии к звездам


Top
   
PostPosted: Thu Sep 20, 2018 5:05 pm 
Offline

Joined: Sun Oct 30, 2011 6:43 pm
Posts: 1499
Есть ещё такой баг:
    пишем текст "0123456789"
    ставим курсор в самое начало
    нажимаем Shift и одновременно Backspace
    отпускаем Shift и Backspace
    нажимаем End
Или другой вариант:
    пишем текст "0123456789"
    ставим курсор в самый конец
    нажимаем Shift и одновременно Delete
    отпускаем Shift и Delete
    нажимаем Home
В результате текст "0123456789" становится выделенным, а он не должен выделяться.


Top
   
PostPosted: Thu Sep 20, 2018 5:13 pm 
Offline

Joined: Sun Oct 30, 2011 6:43 pm
Posts: 1499
Quote:
theonlymirage « Чт сен 20, 2018 6:40 am » выложил инфу по второму багу (смотреть первые 1 мин. 30 сек. и читать описание): https://youtu.be/P_a3KaaZmvc
theonlymirage « Чт сен 20, 2018 1:00 pm » :) lol, в описании видоса было так: "Выделяем текст внутри поля ввода с помощью удержания клавиши Shift. Затем не отпуская клавишу Shift нажимаем Backspace."
Я попробовал это пофиксить. Желательно проверить.
#7400


Top
   
PostPosted: Thu Sep 20, 2018 10:12 pm 
Offline

Joined: Sat Apr 22, 2017 6:11 pm
Posts: 222
0CodErr wrote:
Quote:
theonlymirage « Чт сен 20, 2018 6:40 am » выложил инфу по второму багу (смотреть первые 1 мин. 30 сек. и читать описание): https://youtu.be/P_a3KaaZmvc
theonlymirage « Чт сен 20, 2018 1:00 pm » :) lol, в описании видоса было так: "Выделяем текст внутри поля ввода с помощью удержания клавиши Shift. Затем не отпуская клавишу Shift нажимаем Backspace."
Я попробовал это пофиксить. Желательно проверить.
#7400


Подтверждаю, что баг перестал воспроизводиться, но некоторые приложения могут потребовать обновления. Мне в Hot angles придётся тоже обновить поля, они завязаны на editbox.inc из примера, примеры в programs/develop/examples тоже нужно обновить.

Ещё один баг: в работе копирование/вставка из буфера обмена в этих же приложениях. Берём текст с описанием syscall'ов, выделяем всё и копируем в run, eolite и так далее --> наблюдаем вылет приложения. Забавно, что в Hot angles вставка не работает (не реализовывал), но вместо этого добавляется символ '_', приложение не вылетает.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 400 posts ]  Go to page Previous 123 24 25 26 27 Next

All times are UTC+03:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited