Board.KolibriOS.org

Официальный форум KolibriOS
Текущее время: Сб ноя 18, 2017 5:45 am

Часовой пояс: UTC+03:00




Начать новую тему  Ответить на тему  [ 17 сообщений ]  На страницу 1 2 След.
Автор Сообщение
 Заголовок сообщения: Sound driver issue
СообщениеДобавлено: Вт окт 18, 2016 11:44 pm 
Не в сети

Зарегистрирован: Вт окт 18, 2016 11:35 pm
Сообщения: 8
I have a Fujitsu Siemens Esprimo mobile v5535 laptop with SIS Azalia HD audio controller (SIS7502) and with Realtek ALC268 codec, which is fully supported by the Kolibri OS sound driver (intel_hda.sys), yet I have no sound on my laptop. I would like to know if you have any hints where should I look for a problem within the source code of the driver?
P.S. I know assembly programming.


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 12:16 am 
Не в сети
Designer
Аватара пользователя

Зарегистрирован: Чт янв 25, 2007 3:33 pm
Сообщения: 4226
Please, check here http://websvn.kolibrios.org/listing.php ... 294df9d99e
Also open Debug Board (there is desktop icon), close it and check /rd/1/boardlog.txt for the driver info.

_________________
Через тернии к звездам


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 1:05 am 
Не в сети

Зарегистрирован: Вт окт 18, 2016 11:35 pm
Сообщения: 8
Leency писал(а):
Please, check here http://websvn.kolibrios.org/listing.php ... 294df9d99e
Also open Debug Board (there is desktop icon), close it and check /rd/1/boardlog.txt for the driver info.


I have got this boardlog text:

Спойлер: Показать
K : HPET caps 10398201
K : using mwait for idle loop
K : kernel SVN r6576
K : 2 CPU detected
K : IDE controller programming interface 0001018A
K : BAR0 IDE base addr 01F0
K : BAR1 IDE base addr 03F4
K : BAR2 IDE base addr 0170
K : BAR3 IDE base addr 0374
K : BAR4 IDE controller register base addr 1000
K : IDE Interrupt FF
K : IDE controller programming interface 0001018F
K : BAR0 IDE base addr 1058
K : BAR1 IDE base addr 104C
K : BAR2 IDE base addr 1050
K : BAR3 IDE base addr 1048
K : BAR4 IDE controller register base addr 1020
K : IDE Interrupt 05
K : Channel 1 Disk 0
K : Dev: HL-DT-ST DVDRAM GSA-T20N
K : PIO possible modes 03
K : PIO set mode 01
K : Multiword DMA possible modes 07
K : Multiword DMA set mode 00
K : Ultra DMA possible modes 07
K : Ultra DMA set mode 02
K : Channel 1 Disk 1
K : Device not found
K : Channel 2 Disk 0
K : Device not found
K : Channel 2 Disk 1
K : Device not found
K : Channel 1 Disk 0
K : Dev: WDC WD1600BEVS-07RST0
K : PIO possible modes 03
K : PIO set mode 00
K : Multiword DMA possible modes 07
K : Multiword DMA set mode 00
K : Ultra DMA possible modes 7F
K : Ultra DMA set mode 06
K : Channel 1 Disk 1
K : Device not found
K : Channel 2 Disk 0
K : Device not found
K : Channel 2 Disk 1
K : Device not found
K : IDE CH1 PIO, because ATAPI drive present
K : IDE CH2 PIO because no devices
K : Attach Interrupt 14 Handler 8002BF74
K : Set IDE IRQ14 return code 800604F0
K : Attach Interrupt 15 Handler 8002BF74
K : Set IDE IRQ15 return code 80060504
K : IDE CH1 DMA enabled
K : IDE CH2 PIO because no devices
K : Attach Interrupt 5 Handler 8002BF74
K : Set IDE IRQ5 return code 80060518
K : driver /rd/1/drivers/vidintel.sys mapped to 8104C000
K : driver /sys/drivers/OHCI.sys mapped to 81050000
K : driver /sys/drivers/EHCI.sys mapped to 8104D000
K : has_ownership
K : HCSPARAMS=00102408, HCCPARAMS=00007070
K : Attach Interrupt 7 Handler 8104D8E6
K : EHCI controller at 00:1B with 8 ports initialized
K : Attach Interrupt 11 Handler 810506C3
K : OHCI controller at 00:18 with 4 ports initialized
K : EHCI 810570A4: status of port 2 changed to 00001803
K : Attach Interrupt 10 Handler 810506C3
K : OHCI controller at 00:19 with 4 ports initialized
K : cpu frequency 1831891000 Hz
K : Attach Interrupt 1 Handler 80027B7C
K : IRQ1 return code 80060568
K : driver /rd/1/drivers/PS2MOUSE.SYS mapped to 81168000
K : Attach Interrupt 12 Handler 81168567
L: /SYS/SETUP Param: BOOT
L: /SYS/LOADDRV Param: RDC
K : driver /sys/drivers/RDC.sys mapped to 8116C000
L: /SYS/@TASKBAR Param:
L: /SYS/@ICON Param:
L: /SYS/ESKIN Param:
L: /SYS/@DOCKY Param:
L: /SYS/NETWORK/NETCFG Param: A
K : EHCI 810570A4 port 2 state is 00001801
K : EHCI 810570A4: port 2 has HS or FS device, resetting
K : EHCI 810570A4 status of port 2 is 00001005
K : warning: async advance int missed
K : device descriptor: 12 01 00 02 00 00 00 40 30 09 44 65 00 01 01 02 03 01
K : found USB device with ID 0930:6544, 1 configuration(s)
K : config descriptor: 09 02 20 00 01 01 00 80 64 09 04 00 00 02 08 06 50 00 07 05 81 02 00 02 FF 07 05 02 02 00 02 FF
K : USB interface class/subclass/protocol = 08/06/50
K : driver /sys/drivers/usbstor.sys mapped to 811B4000
K : USB mass storage device detected
K : 1 logical unit(s)
L: /SYS/NETWORK/@ZEROCONF Param:
K : media is ready
K : 0 attempts, 2 ticks
K : peripheral device type is 00
K : direct-access mass storage device detected
K : sector size is 512, last sector is 30297215
Zero-config service loaded
L: /SYS/@VOLUME Param:
K : driver /sys/drivers/SOUND.sys mapped to 8118A000
Detecting hardware...
Loading INTEL_HDA
K : driver /sys/drivers/INTEL_HDA.sys mapped to 811C0000
HDA test version 019
detect hardware...
SIS 966
PCI command 00000006
PCI status 00000210
lower mmio base D4200000
upper mmio base 00000000
GCAP = 00004400
codec_mask = 00000003
create primary buffer ...done
K : Attach Interrupt 3 Handler 811C0A4C
codec probed OK
CAd = 0
L: /SYS/@SS Param: ASSM
Setup FG nodes = start_nid:total_nodes = 1:1
L: /SYS/TMPDISK Param: A0
FG type = 1
Setup FG nodes = start_nid:total_nodes = 2:23
K : driver /sys/drivers/tmpdisk.sys mapped to 811BC000
trying to add disk

its size is not specified, 20% from free RAM will be used

new DiskSize: 559 MB

operation completed successfully

L: /SYS/SEARCHAP Param:
Realtek ALC268
Pin Nid = 14
Pin Control = 00000020
Pin Capabilities = 0001003C
Pin def_cfg = 99138110
Pin Amp Out caps = 80000000
AUD_OUT found 2
UNMUTE OUT: NID=2
Amp val = 40:3
CONNECT: NID=F
IDX=0
UNMUTE OUT: NID=14
Enable EAPD: NID=14
UNMUTE OUT: NID=14
Enable EAPD: NID=14
Pin Nid = 15
Pin Control = 00000020
Pin Capabilities = 0001003C
Pin def_cfg = 0121441F
Pin Amp Out caps = 80000000
AUD_OUT found 3
UNMUTE OUT: NID=3
Amp val = 40:3
CONNECT: NID=10
IDX=0
UNMUTE OUT: NID=15
Enable EAPD: NID=15
UNMUTE OUT: NID=15
Enable EAPD: NID=15
val=2
val=3
hda_codec_setup_stream: NID=3
stream=1
channel=0
format=11
hda_codec_setup_stream: NID=2
stream=1
channel=0
format=11
Normal mode !
NewVolume: 0000095B
MinVolume: 000012C0
Searchap: additional partition is not found!
L: AUTORUN.DAT processed
K : destroy app object


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 12:19 pm 
Не в сети
Designer
Аватара пользователя

Зарегистрирован: Чт янв 25, 2007 3:33 pm
Сообщения: 4226
Did you try to open some MP3 file via /rd/1/media/ac97snd or via /rd/1/media/pixie/pixie ?

_________________
Через тернии к звездам


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 12:30 pm 
Не в сети

Зарегистрирован: Вт окт 18, 2016 11:35 pm
Сообщения: 8
Yes I have tried to open mp3 files and midi files. Still no sound on my laptop.

I forgot to say that i have a SIS968 southbridge. In the intel_hda driver source code only SIS966 is defined as a controller.


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 2:25 pm 
Не в сети
Designer
Аватара пользователя

Зарегистрирован: Чт янв 25, 2007 3:33 pm
Сообщения: 4226
I'm not really good in drivers area.

Maybe you could you try to:
1. go to Kolibri and open /rd/1/run app
2. run the next line: loaddrv /rd/1/sis.sys

Another option is to add your southbridge to http://websvn.kolibrios.org/filedetails ... el_hda.asm

_________________
Через тернии к звездам


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 3:26 pm 
Не в сети

Зарегистрирован: Вт окт 18, 2016 11:35 pm
Сообщения: 8
It wont load the sis.sys driver because this driver is for SIS7012 audio controller with AC97 codec.

I think that the problem is somewhere within intel_hda.sys. I will try to find the problem in the source code.


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 4:36 pm 
Не в сети
Kernel Developer
Аватара пользователя

Зарегистрирован: Чт сен 03, 2009 1:52 pm
Сообщения: 1600
codec_mask = 3 is somewhat unusual - it means that there are two codecs, and I would not be surprised if the incorrect one ends up being selected. As a quick check, replace line #1315 of intel_hda.asm "mov [ctrl.codec_mask], eax" with "mov [ctrl.codec_mask], 2" and check whether it helps.

_________________
Сделаем мир лучше!


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 6:15 pm 
Не в сети

Зарегистрирован: Вт окт 18, 2016 11:35 pm
Сообщения: 8
I have modified and reassembled the intel_hda driver. I tried out multiple codec_mask values (from 0 to 4).
codec_mask = 0 gives nothing
codec_mask = 1 gives ALC268
codec_mask = 2 gives a Motorola device, which is a modem on my laptop
codec_mask = 3 gives ALC268
codec_mask = 4 gives nothing

After all this I have no sound.

boardlog when codec_mask = 1
Спойлер: Показать
K : HPET caps 10398201
K : using mwait for idle loop
K : kernel SVN r6576
K : 2 CPU detected
K : IDE controller programming interface 0001018A
K : BAR0 IDE base addr 01F0
K : BAR1 IDE base addr 03F4
K : BAR2 IDE base addr 0170
K : BAR3 IDE base addr 0374
K : BAR4 IDE controller register base addr 1000
K : IDE Interrupt FF
K : IDE controller programming interface 0001018F
K : BAR0 IDE base addr 1058
K : BAR1 IDE base addr 104C
K : BAR2 IDE base addr 1050
K : BAR3 IDE base addr 1048
K : BAR4 IDE controller register base addr 1020
K : IDE Interrupt 05
K : Channel 1 Disk 0
K : Dev: HL-DT-ST DVDRAM GSA-T20N
K : PIO possible modes 03
K : PIO set mode 01
K : Multiword DMA possible modes 07
K : Multiword DMA set mode 00
K : Ultra DMA possible modes 07
K : Ultra DMA set mode 02
K : Channel 1 Disk 1
K : Device not found
K : Channel 2 Disk 0
K : Device not found
K : Channel 2 Disk 1
K : Device not found
K : Channel 1 Disk 0
K : Dev: WDC WD1600BEVS-07RST0
K : PIO possible modes 03
K : PIO set mode 00
K : Multiword DMA possible modes 07
K : Multiword DMA set mode 00
K : Ultra DMA possible modes 7F
K : Ultra DMA set mode 06
K : Channel 1 Disk 1
K : Device not found
K : Channel 2 Disk 0
K : Device not found
K : Channel 2 Disk 1
K : Device not found
K : IDE CH1 PIO, because ATAPI drive present
K : IDE CH2 PIO because no devices
K : Attach Interrupt 14 Handler 8002BF74
K : Set IDE IRQ14 return code 800604F0
K : Attach Interrupt 15 Handler 8002BF74
K : Set IDE IRQ15 return code 80060504
K : IDE CH1 DMA enabled
K : IDE CH2 PIO because no devices
K : Attach Interrupt 5 Handler 8002BF74
K : Set IDE IRQ5 return code 80060518
K : driver /rd/1/drivers/vidintel.sys mapped to 8104C000
K : driver /sys/drivers/OHCI.sys mapped to 81050000
K : driver /sys/drivers/EHCI.sys mapped to 8104D000
K : has_ownership
K : HCSPARAMS=00102408, HCCPARAMS=00007070
K : Attach Interrupt 7 Handler 8104D8E6
K : EHCI controller at 00:1B with 8 ports initialized
K : Attach Interrupt 11 Handler 810506C3
K : OHCI controller at 00:18 with 4 ports initialized
K : Attach Interrupt 10 Handler 810506C3
K : OHCI controller at 00:19 with 4 ports initialized
K : EHCI 810570A4: status of port 2 changed to 00001803
K : cpu frequency 1831891000 Hz
K : Attach Interrupt 1 Handler 80027B7C
K : IRQ1 return code 80060568
K : driver /rd/1/drivers/PS2MOUSE.SYS mapped to 81168000
K : Attach Interrupt 12 Handler 81168567
L: /SYS/SETUP Param: BOOT
L: /SYS/LOADDRV Param: RDC
K : driver /sys/drivers/RDC.sys mapped to 8116C000
L: /SYS/@TASKBAR Param:
L: /SYS/@ICON Param:
L: /SYS/ESKIN Param:
L: /SYS/@DOCKY Param:
L: /SYS/NETWORK/NETCFG Param: A
K : EHCI 810570A4 port 2 state is 00001801
K : EHCI 810570A4: port 2 has HS or FS device, resetting
K : EHCI 810570A4 status of port 2 is 00001005
K : warning: async advance int missed
K : device descriptor: 12 01 00 02 00 00 00 40 30 09 44 65 00 01 01 02 03 01
K : found USB device with ID 0930:6544, 1 configuration(s)
K : config descriptor: 09 02 20 00 01 01 00 80 64 09 04 00 00 02 08 06 50 00 07 05 81 02 00 02 FF 07 05 02 02 00 02 FF
K : USB interface class/subclass/protocol = 08/06/50
K : driver /sys/drivers/usbstor.sys mapped to 811B4000
K : USB mass storage device detected
K : 1 logical unit(s)
L: /SYS/NETWORK/@ZEROCONF Param:
K : media is ready
K : 0 attempts, 2 ticks
K : peripheral device type is 00
K : direct-access mass storage device detected
K : sector size is 512, last sector is 30297215
Zero-config service loaded
L: /SYS/@VOLUME Param:
K : driver /sys/drivers/SOUND.sys mapped to 8118A000
Detecting hardware...
Loading INTEL_HDA
K : driver /sys/drivers/INTEL_HDA.sys mapped to 811BE000
HDA test version 019
detect hardware...
SIS 966
PCI command 00000006
PCI status 00000210
lower mmio base D4200000
upper mmio base 00000000
GCAP = 00004400
codec_mask = 00000003
create primary buffer ...done
K : Attach Interrupt 3 Handler 811BEA4C
codec probed OK
CAd = 0
L: /SYS/@SS Param: ASSM
Setup FG nodes = start_nid:total_nodes = 1:1
FG type = 1
L: /SYS/TMPDISK Param: A0
Setup FG nodes = start_nid:total_nodes = 2:23
K : driver /sys/drivers/tmpdisk.sys mapped to 811BA000
trying to add disk

its size is not specified, 20% from free RAM will be used

new DiskSize: 559 MB

operation completed successfully

L: /SYS/SEARCHAP Param:
Realtek ALC268
Pin Nid = 14
Pin Control = 00000020
Pin Capabilities = 0001003C
Pin def_cfg = 99138110
Pin Amp Out caps = 80000000
AUD_OUT found 2
UNMUTE OUT: NID=2
Amp val = 40:3
CONNECT: NID=F
IDX=0
UNMUTE OUT: NID=14
Enable EAPD: NID=14
UNMUTE OUT: NID=14
Enable EAPD: NID=14
Pin Nid = 15
Pin Control = 00000020
Pin Capabilities = 0001003C
Pin def_cfg = 0121441F
Pin Amp Out caps = 80000000
AUD_OUT found 3
UNMUTE OUT: NID=3
Amp val = 40:3
CONNECT: NID=10
IDX=0
UNMUTE OUT: NID=15
Enable EAPD: NID=15
UNMUTE OUT: NID=15
Enable EAPD: NID=15
val=2
val=3
hda_codec_setup_stream: NID=3
stream=1
channel=0
format=11
hda_codec_setup_stream: NID=2
stream=1
channel=0
format=11
Normal mode !
NewVolume: 000001DF
MinVolume: 000012C0
Searchap: additional partition is not found!
L: AUTORUN.DAT processed
TRK Notes: max=76 min=60
K : destroy app object
K : destroy app object


boardlog when codec_mask = 2
Спойлер: Показать
K : HPET caps 10398201
K : using mwait for idle loop
K : kernel SVN r6576
K : 2 CPU detected
K : IDE controller programming interface 0001018A
K : BAR0 IDE base addr 01F0
K : BAR1 IDE base addr 03F4
K : BAR2 IDE base addr 0170
K : BAR3 IDE base addr 0374
K : BAR4 IDE controller register base addr 1000
K : IDE Interrupt FF
K : IDE controller programming interface 0001018F
K : BAR0 IDE base addr 1058
K : BAR1 IDE base addr 104C
K : BAR2 IDE base addr 1050
K : BAR3 IDE base addr 1048
K : BAR4 IDE controller register base addr 1020
K : IDE Interrupt 05
K : Channel 1 Disk 0
K : Dev: HL-DT-ST DVDRAM GSA-T20N
K : PIO possible modes 03
K : PIO set mode 01
K : Multiword DMA possible modes 07
K : Multiword DMA set mode 00
K : Ultra DMA possible modes 07
K : Ultra DMA set mode 02
K : Channel 1 Disk 1
K : Device not found
K : Channel 2 Disk 0
K : Device not found
K : Channel 2 Disk 1
K : Device not found
K : Channel 1 Disk 0
K : Dev: WDC WD1600BEVS-07RST0
K : PIO possible modes 03
K : PIO set mode 00
K : Multiword DMA possible modes 07
K : Multiword DMA set mode 00
K : Ultra DMA possible modes 7F
K : Ultra DMA set mode 06
K : Channel 1 Disk 1
K : Device not found
K : Channel 2 Disk 0
K : Device not found
K : Channel 2 Disk 1
K : Device not found
K : IDE CH1 PIO, because ATAPI drive present
K : IDE CH2 PIO because no devices
K : Attach Interrupt 14 Handler 8002BF74
K : Set IDE IRQ14 return code 800604F0
K : Attach Interrupt 15 Handler 8002BF74
K : Set IDE IRQ15 return code 80060504
K : IDE CH1 DMA enabled
K : IDE CH2 PIO because no devices
K : Attach Interrupt 5 Handler 8002BF74
K : Set IDE IRQ5 return code 80060518
K : driver /rd/1/drivers/vidintel.sys mapped to 8104C000
K : driver /sys/drivers/OHCI.sys mapped to 81050000
K : driver /sys/drivers/EHCI.sys mapped to 8104D000
K : has_ownership
K : HCSPARAMS=00102408, HCCPARAMS=00007070
K : Attach Interrupt 7 Handler 8104D8E6
K : EHCI controller at 00:1B with 8 ports initialized
K : Attach Interrupt 11 Handler 810506C3
K : OHCI controller at 00:18 with 4 ports initialized
K : Attach Interrupt 10 Handler 810506C3
K : OHCI controller at 00:19 with 4 ports initialized
K : cpu frequency 1831891000 Hz
K : Attach Interrupt 1 Handler 80027B7C
K : IRQ1 return code 80060568
K : driver /rd/1/drivers/PS2MOUSE.SYS mapped to 81168000
K : Attach Interrupt 12 Handler 81168567
K : EHCI 810570A4: status of port 1 changed to 00001803
L: /SYS/SETUP Param: BOOT
L: /SYS/LOADDRV Param: RDC
K : driver /sys/drivers/RDC.sys mapped to 8116C000
L: /SYS/@TASKBAR Param:
L: /SYS/@ICON Param:
L: /SYS/ESKIN Param:
L: /SYS/@DOCKY Param:
L: /SYS/NETWORK/NETCFG Param: A
K : EHCI 810570A4 port 1 state is 00001801
K : EHCI 810570A4: port 1 has HS or FS device, resetting
K : EHCI 810570A4 status of port 1 is 00001005
K : warning: async advance int missed
K : device descriptor: 12 01 00 02 00 00 00 40 30 09 44 65 00 01 01 02 03 01
K : found USB device with ID 0930:6544, 1 configuration(s)
K : config descriptor: 09 02 20 00 01 01 00 80 64 09 04 00 00 02 08 06 50 00 07 05 81 02 00 02 FF 07 05 02 02 00 02 FF
K : USB interface class/subclass/protocol = 08/06/50
K : driver /sys/drivers/usbstor.sys mapped to 811B1000
K : USB mass storage device detected
K : 1 logical unit(s)
L: /SYS/NETWORK/@ZEROCONF Param:
K : media is ready
K : 0 attempts, 2 ticks
K : peripheral device type is 00
K : direct-access mass storage device detected
K : sector size is 512, last sector is 30297215
Zero-config service loaded
L: /SYS/@VOLUME Param:
K : driver /sys/drivers/SOUND.sys mapped to 81194000
Detecting hardware...
Loading INTEL_HDA
K : driver /sys/drivers/INTEL_HDA.sys mapped to 811BE000
HDA test version 019
detect hardware...
SIS 966
PCI command 00000006
PCI status 00000210
lower mmio base D4200000
upper mmio base 00000000
GCAP = 00004400
codec_mask = 00000003
create primary buffer ...done
K : Attach Interrupt 3 Handler 811BEA4C
codec probed OK
CAd = 1
L: /SYS/@SS Param: ASSM
Setup FG nodes = start_nid:total_nodes = 1:1
FG type = 2
no AFG node found, trying another codec
L: /SYS/TMPDISK Param: A0
Setup FG nodes = start_nid:total_nodes = 2:24
K : driver /sys/drivers/tmpdisk.sys mapped to 811BB000
trying to add disk

its size is not specified, 20% from free RAM will be used

new DiskSize: 559 MB

operation completed successfully

L: /SYS/SEARCHAP Param:
Motorola unknown codec id 00003055
val=0
device not found
K : destroy app object
Searchap: additional partition is not found!
L: AUTORUN.DAT processed


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 7:22 pm 
Не в сети
Аватара пользователя

Зарегистрирован: Пт июн 27, 2008 3:22 pm
Сообщения: 974
For the beginning get full debug information by setting
Код:
FDEBUG          equ 1

in the file intel_hda.asm


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 7:41 pm 
Не в сети

Зарегистрирован: Вт окт 18, 2016 11:35 pm
Сообщения: 8
I have set FDEBUG to 1 and assembled the intel_hda.asm file. I got the following boardlog:

Спойлер: Показать
K : HPET caps 10398201
K : using mwait for idle loop
K : kernel SVN r6576
K : 2 CPU detected
K : IDE controller programming interface 0001018A
K : BAR0 IDE base addr 01F0
K : BAR1 IDE base addr 03F4
K : BAR2 IDE base addr 0170
K : BAR3 IDE base addr 0374
K : BAR4 IDE controller register base addr 1000
K : IDE Interrupt FF
K : IDE controller programming interface 0001018F
K : BAR0 IDE base addr 1058
K : BAR1 IDE base addr 104C
K : BAR2 IDE base addr 1050
K : BAR3 IDE base addr 1048
K : BAR4 IDE controller register base addr 1020
K : IDE Interrupt 05
K : Channel 1 Disk 0
K : Dev: HL-DT-ST DVDRAM GSA-T20N
K : PIO possible modes 03
K : PIO set mode 01
K : Multiword DMA possible modes 07
K : Multiword DMA set mode 00
K : Ultra DMA possible modes 07
K : Ultra DMA set mode 02
K : Channel 1 Disk 1
K : Device not found
K : Channel 2 Disk 0
K : Device not found
K : Channel 2 Disk 1
K : Device not found
K : Channel 1 Disk 0
K : Dev: WDC WD1600BEVS-07RST0
K : PIO possible modes 03
K : PIO set mode 00
K : Multiword DMA possible modes 07
K : Multiword DMA set mode 00
K : Ultra DMA possible modes 7F
K : Ultra DMA set mode 06
K : Channel 1 Disk 1
K : Device not found
K : Channel 2 Disk 0
K : Device not found
K : Channel 2 Disk 1
K : Device not found
K : IDE CH1 PIO, because ATAPI drive present
K : IDE CH2 PIO because no devices
K : Attach Interrupt 14 Handler 8002BF74
K : Set IDE IRQ14 return code 800604F0
K : Attach Interrupt 15 Handler 8002BF74
K : Set IDE IRQ15 return code 80060504
K : IDE CH1 DMA enabled
K : IDE CH2 PIO because no devices
K : Attach Interrupt 5 Handler 8002BF74
K : Set IDE IRQ5 return code 80060518
K : driver /rd/1/drivers/vidintel.sys mapped to 8104C000
K : driver /sys/drivers/OHCI.sys mapped to 81050000
K : driver /sys/drivers/EHCI.sys mapped to 8104D000
K : has_ownership
K : HCSPARAMS=00102408, HCCPARAMS=00007070
K : Attach Interrupt 7 Handler 8104D8E6
K : EHCI controller at 00:1B with 8 ports initialized
K : Attach Interrupt 11 Handler 810506C3
K : OHCI controller at 00:18 with 4 ports initialized
K : Attach Interrupt 10 Handler 810506C3
K : OHCI controller at 00:19 with 4 ports initialized
K : EHCI 810570A4: status of port 1 changed to 00001803
K : cpu frequency 1831891000 Hz
K : Attach Interrupt 1 Handler 80027B7C
K : IRQ1 return code 80060568
K : driver /rd/1/drivers/PS2MOUSE.SYS mapped to 81168000
K : Attach Interrupt 12 Handler 81168567
L: /SYS/SETUP Param: BOOT
L: /SYS/LOADDRV Param: RDC
K : driver /sys/drivers/RDC.sys mapped to 81174000
L: /SYS/@TASKBAR Param:
L: /SYS/@ICON Param:
L: /SYS/ESKIN Param:
L: /SYS/@DOCKY Param:
L: /SYS/NETWORK/NETCFG Param: A
K : EHCI 810570A4 port 1 state is 00001801
K : EHCI 810570A4: port 1 has HS or FS device, resetting
K : EHCI 810570A4 status of port 1 is 00001005
K : warning: async advance int missed
K : device descriptor: 12 01 00 02 00 00 00 40 30 09 44 65 00 01 01 02 03 01
K : found USB device with ID 0930:6544, 1 configuration(s)
K : config descriptor: 09 02 20 00 01 01 00 80 64 09 04 00 00 02 08 06 50 00 07 05 81 02 00 02 FF 07 05 02 02 00 02 FF
K : USB interface class/subclass/protocol = 08/06/50
K : driver /sys/drivers/usbstor.sys mapped to 81194000
K : USB mass storage device detected
K : 1 logical unit(s)
L: /SYS/NETWORK/@ZEROCONF Param:
Zero-config service loaded
L: /SYS/@VOLUME Param:
K : driver /sys/drivers/SOUND.sys mapped to 81192000
Detecting hardware...
Loading INTEL_HDA
K : driver /sys/drivers/INTEL_HDA.sys mapped to 811CA000
HDA test version 019
detect hardware...
SIS 966
PCI command 00000006
PCI status 00000210
lower mmio base D4200000
upper mmio base 00000000
GCAP = 00004400
codec_mask = 00000003
create primary buffer ...done
K : Attach Interrupt 3 Handler 811CAA70
K : media is ready
K : 0 attempts, 2 ticks
K : peripheral device type is 00
K : direct-access mass storage device detected
K : sector size is 512, last sector is 30297215
codec probed OK
CAd = 0
Q: 000F0000
A: 10EC0268
Q: 000F0001
L: /SYS/@SS Param: ASSM
Q: 000F0002
A: 00100003
Q: 000F0004
A: 00010001
Setup FG nodes = start_nid:total_nodes = 1:1
Q: 001F0005
L: /SYS/TMPDISK Param: A0
A: 00000101
FG type = 1
Q: 001F0004
A: 00020023
Setup FG nodes = start_nid:total_nodes = 2:23
Widget capabilities:
Q: 002F0009
A: 0000001D
Q: 003F0009
K : driver /sys/drivers/tmpdisk.sys mapped to 811BB000
trying to add disk

its size is not specified, 20% from free RAM will be used

new DiskSize: 559 MB

A: 0000001D
Q: 004F0009
A: 00F00000
Q: 005F0009
A: 00F00000
Q: 006F0009
A: 00000211
Q: 007F0009
A: 00100111
Q: 008F0009
A: 00100111
Q: 009F0009
A: 00F00000
Q: 00AF0009
A: 00F00000
Q: 00BF0009
operation completed successfully

A: 00F00000
Q: 00CF0009
L: /SYS/SEARCHAP Param:
A: 00F00000
Q: 00DF0009
A: 00F00000
Q: 00EF0009
A: 0020010A
Q: 00FF0009
A: 0020010B
Q: 010F0009
A: 0020010B
Q: 011F0009
A: 00F00000
Q: 012F0009
A: 00400001
Q: 013F0009
A: 00400001
Q: 014F0009
A: 0040018D
Q: 015F0009
A: 0040018D
Q: 016F0009
A: 0040010C
Q: 017F0009
A: 00F00000
Q: 018F0009
A: 0040018F
Q: 019F0009
A: 0040008B
Q: 01AF0009
A: 0040018F
Q: 01BF0009
A: 00F00000
Q: 01CF0009
A: 00400001
Q: 01DF0009
A: 00400000
Q: 01EF0009
A: 00400380
Q: 01FF0009
A: 00F00000
Q: 020F0009
A: 00F00040
Q: 021F0009
A: 00F00000
Q: 022F0009
A: 00F00000
Q: 023F0009
A: 0030010D
Q: 024F0009
A: 0030010D
Pin configurations:
Q: 012F1C00
A: 411111F0
Q: 013F1C00
A: 411111F0
Q: 014F1C00
A: 99138110
Q: 015F1C00
A: 0121441F
Q: 016F1C00
A: 411111F0
Q: 018F1C00
A: 01A19C2E
Q: 019F1C00
A: 99A38920
Q: 01AF1C00
A: 411111F0
Q: 01CF1C00
A: 411111F0
Q: 01DF1C00
A: 40138205
Q: 01EF1C00
A: 411111F0
Q: 001F2000
A: 17341110
Q: 00170500
Q: 001F0500
Realtek ALC268
Q: 001F0012
Q: 001F000D
Q: 001F0004
A: 00020023
Q: 002F0012
A: 00034040
Q: 003F0012
A: 00034040
Q: 007F000E
A: 00000001
Q: 007F0200
A: 00000024
Q: 008F000E
A: 00000001
Q: 008F0200
A: 00000023
Q: 00EF000E
A: 00000001
Q: 00EF0200
A: 00000002
Q: 00EF000D
A: 80000000
Q: 00FF000E
A: 00000002
Q: 00FF0200
A: 00001D02
Q: 00FF000D
A: 80000000
Q: 010F000E
A: 00000003
Q: 010F0200
A: 00021D03
Q: 010F000D
A: 80000000
Q: 012F000C
A: 00000020
Q: 012F0700
Q: 013F000C
A: 00000020
Q: 013F0700
Q: 014F000E
A: 00000001
Q: 014F0200
A: 0000000F
Q: 014F000C
A: 0001003C
Q: 014F0700
A: 00000020
Q: 014F0012
A: 80000000
Q: 015F000E
A: 00000001
Q: 015F0200
A: 00000010
Q: 015F000C
A: 0001003C
Q: 015F0700
A: 00000020
Q: 015F0012
A: 80000000
Q: 016F000E
A: 00000001
Q: 016F0200
A: 0000000E
Q: 016F000C
A: 00000010
Q: 016F0700
Q: 016F0012
A: 80000000
Q: 018F000E
A: 00000001
Q: 018F0200
A: 00000002
Q: 018F000C
A: 00003734
Q: 018F0700
A: 00000021
Q: 018F0012
A: 80000000
Q: 018F000D
A: 004F0200
Q: 019F000C
A: 00003724
Q: 019F0700
A: 00000020
Q: 019F000D
A: 004F0200
Q: 01AF000E
A: 00000001
Q: 01AF0200
A: 00000002
Q: 01AF000C
A: 00003734
Q: 01AF0700
A: 00000020
Q: 01AF0012
A: 80000000
Q: 01AF000D
A: 004F0200
Q: 01CF000C
A: 00000020
Q: 01CF0700
A: 00000020
Q: 01DF000C
A: 00000020
Q: 01DF0700
A: 00000020
Q: 01EF000E
A: 00000001
Q: 01EF0200
A: 00000006
Q: 01EF000C
A: 00000010
Q: 01EF0700
A: 00000040
Q: 023F000E
A: 00000007
Q: 023F0200
A: 1C1A1918
Q: 023F0204
A: 00121514
Q: 023F0012
A: 80051F0B
Q: 024F000E
A: 00000007
Q: 024F0200
A: 1C1A1918
Q: 024F0204
A: 00131514
Q: 024F0012
A: 80051F0B
Sequence of codec nodes:
NID: 0x2
NID: 0x3
NID: 0x4
NID: 0x5
NID: 0x6
NID: 0x7
NID: 0x8
NID: 0x9
NID: 0xA
NID: 0xB
NID: 0xC
NID: 0xD
NID: 0xE
NID: 0xF
NID: 0x10
NID: 0x11
NID: 0x17
NID: 0x1B
NID: 0x1F
NID: 0x20
NID: 0x21
NID: 0x22
NID: 0x23
NID: 0x24
NID: 0x1D
NID: 0x14
NID: 0x15
NID: 0x19
NID: 0x18
NID: 0x12
NID: 0x13
NID: 0x16
NID: 0x1A
NID: 0x1C
NID: 0x1E
Q: 014F000C
A: 0001003C
Q: 01470894
Pin Nid = 14
Pin Control = 00000020
Pin Capabilities = 0001003C
Pin def_cfg = 99138110
Pin Amp Out caps = 80000000
AUD_OUT found 2
UNMUTE OUT: NID=2
Q: 0023A040
Q: 00239040
Amp val = 40:3
CONNECT: NID=F
IDX=0
Q: 00F70100
UNMUTE OUT: NID=14
Q: 01470C02
Enable EAPD: NID=14
Q: 0143A000
Q: 01439000
UNMUTE OUT: NID=14
Q: 01470C02
Enable EAPD: NID=14
Q: 0143A000
Q: 01439000
Q: 014707C0
Q: 015F000C
A: 0001003C
Q: 01570895
Pin Nid = 15
Pin Control = 00000020
Pin Capabilities = 0001003C
Pin def_cfg = 0121441F
Pin Amp Out caps = 80000000
AUD_OUT found 3
UNMUTE OUT: NID=3
Q: 0033A040
Q: 00339040
Amp val = 40:3
CONNECT: NID=10
IDX=0
Q: 01070100
UNMUTE OUT: NID=15
Q: 01570C02
Enable EAPD: NID=15
Q: 0153A000
Q: 01539000
UNMUTE OUT: NID=15
Q: 01570C02
Enable EAPD: NID=15
Q: 0153A000
Q: 01539000
Q: 015707C0
val=2
val=3
hda_codec_setup_stream: NID=3
stream=1
channel=0
format=11
Q: 00370610
Q: 00320011
hda_codec_setup_stream: NID=2
stream=1
channel=0
format=11
Q: 00270610
Q: 00220011
Normal mode !
NewVolume: 000001DF
MinVolume: 000012C0
Q: 0033A039
Q: 00339039
Searchap: additional partition is not found!
L: AUTORUN.DAT processed
minimp3 -- a small MPEG-1 Audio Layer III player based on ffmpeg

/usbhd0/1/002.MP3
Bytes:5782091
Now Playing: /usbhd0/1/002.MP3
samples:44100
channel:2K : driver /sys/drivers/INFINITY.sys mapped to A4404000
start play
K : destroy app object


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 7:54 pm 
Не в сети
Mentor/Kernel Developer
Аватара пользователя

Зарегистрирован: Пт июн 30, 2006 9:01 am
Сообщения: 1232
Just to be sure..
Did you also check the headphone jack or just built-in speakers?

_________________
"Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius -- and a lot of courage -- to move in the opposite direction." Albert Einstein


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 7:56 pm 
Не в сети
Аватара пользователя

Зарегистрирован: Пт июн 27, 2008 3:22 pm
Сообщения: 974
Ok, thanks. I'll get some time to analyze the log.


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 9:13 pm 
Не в сети

Зарегистрирован: Вт окт 18, 2016 11:35 pm
Сообщения: 8
hidnplayr писал(а):
Just to be sure..
Did you also check the headphone jack or just built-in speakers?


Yes I checked the headphone jack. The boardlog shows unsolicited events, but there is no sound.


Вернуться к началу
 Заголовок сообщения: Re: Sound driver issue
СообщениеДобавлено: Ср окт 19, 2016 10:29 pm 
Не в сети
Designer
Аватара пользователя

Зарегистрирован: Чт янв 25, 2007 3:33 pm
Сообщения: 4226
Try attached driver. It is a bit newer version than in distro, also it should support headphones.


Вложения:
intel_hda.sys [6.95 КБ]
21 скачивание

_________________
Через тернии к звездам
Вернуться к началу
Показать сообщения за:  Поле сортировки  
Начать новую тему  Ответить на тему  [ 17 сообщений ]  На страницу 1 2 След.

Часовой пояс: UTC+03:00


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Limited
Русская поддержка phpBB